Centos 5 on Intel P35 based ASUS Motherboard


Few months ago I decide to buy a new computer for our hosting services that planned to be colocated at Jakarta (directly connected with IIX – Indonesian Internet eXchange). The specs was great (Q6600 – Intel QuadCore, with 4Gb of RAM, and P5KC Asus Motherboard). Sadly my favourite CentOS cannot be installed smoothly. But thank god now server is up and running with CentOS 5 and CPANEL installed – ready to roar!!!

Here’s some problem before :

  1. DVD-ROM was detected, but no SATA Disk detected
    Solution : put acpi=off on /etc/grub.conf, but problem no. 2 comes up
  2. Installation went through smoothly, but SATA disks are detected as IDE
    So I got a very poor disks performance. Usualy when I perform “hdparm -Tt /dev/sdX” on SATA disks, Timing buffered disk reads will hit 60 – 70MB/sec. But on my new machine, it shows only 4MB/sec. And it’s not detected as sdX, but hdX 😦
  3. Attansic onboard ethernet is not detected
    But it’s quite easy to solve this problem. Just put Centos compatible ethernet, or download attansic ethernet driver for linux. I do both of it (hey .. we need backup right?)

What I most concerned is problem No#2. Get real!! 4MB/sec?

I think this problem because Centos kernel that delivered on installation DVD haven’t support JMicron controller. I have try to install it with SATA DVD-ROM, but I got the same result.

So here’s what I do :

  1. I install Centos 5 on my old ASUS P5LD2-VM SE board
    My goals is get my disks detected as SATA
  2. Update kernel to the latest which is currently 2.6.18-53-PAE
    I use PAE kernel because non-PAE only detect 3 of 4GB RAM. But the main reason is to get the latest JMicron driver for SATA controller
  3. I put installed SATA disk on ASUS P5KC motherboard and add “ide[n]=noprobe” (n = device number) so that Centos wont try to probe the disk with old IDE driver
  4. Download Attansic ethernet driver and compile it

That’s it!

Advertisements

About piyecarane

Bla bla bla about me
This entry was posted in Hosting, Linux and tagged , , , , , , . Bookmark the permalink.

2 Responses to Centos 5 on Intel P35 based ASUS Motherboard

  1. me says:

    Hello!

    I am going to buy a new computer, and i need to run CentOS 5(.2) on it… Have you ever tried to install the latest CentOS version on such a motherboard? I’d also prefer a smooth installation! 🙂

  2. piyecarane says:

    What kind of mobo?
    I have tried install it on ASUS P2BF (Centos 5), ASUS P5KC (Centos 5.1 32 bit), and ASUS P5KR (Centos 5.2 64bit). All now smoothly running although there’s some problems during installation

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s